Алгоритм
<<  Исполнитель Чертежник Исполнитель Робот  >>
Исполнитель Робот
Исполнитель Робот
Обстановка Робота
Обстановка Робота
Робот-> Сменить стартовую обстановку
Робот-> Сменить стартовую обстановку
Исполнитель Робот
Исполнитель Робот
Инструменты->Редактировать стартовую обстановку
Инструменты->Редактировать стартовую обстановку
Исполнитель Робот
Исполнитель Робот
Исполнитель Робот
Исполнитель Робот
Описание алгоритма
Описание алгоритма
Система команд исполнителя «Робот» включает:
Система команд исполнителя «Робот» включает:
Пример:
Пример:
Команды циклических алгоритмов
Команды циклических алгоритмов
Задача 1 На поле Робота нет стен и закрашенных клеток
Задача 1 На поле Робота нет стен и закрашенных клеток
Задача 4
Задача 4
Задача 5 - 6
Задача 5 - 6
Цикл N раз
Цикл N раз
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример использования цикла
Пример
Пример
Нарисуем треугольник
Нарисуем треугольник
Еще один пример
Еще один пример
Домашнее задание
Домашнее задание
Робот находится в левом верхнем углу поля
Робот находится в левом верхнем углу поля
Робот находится в левом верхнем углу поля
Робот находится в левом верхнем углу поля
Б
Б
Цикл пока
Цикл пока
10 команд проверки условий
10 команд проверки условий
Закрашивание ряда до стены
Закрашивание ряда до стены
Закрашивание горизонтального коридора произвольной длины, робот где-то
Закрашивание горизонтального коридора произвольной длины, робот где-то
Задания
Задания
Величины
Величины
Величины
Величины
Вывести два числа, вывести их сумму
Вывести два числа, вывести их сумму
Цикл «для»
Цикл «для»
Исполнитель Робот
Исполнитель Робот
Закрасить клетки по периметру прямоугольника размером X на Y
Закрасить клетки по периметру прямоугольника размером X на Y
Цикл n раз
Цикл n раз
использовать Робот алг нач нц 5 раз · закрасить;вправо;вверх кц нц 5
использовать Робот алг нач нц 5 раз · закрасить;вправо;вверх кц нц 5
Исполнитель Робот
Исполнитель Робот
Исполнитель Робот
Исполнитель Робот
Вложенные циклы
Вложенные циклы
использовать Робот алг УЗОР нач нц 2 раз нц 4 раз закрасить; вниз вниз
использовать Робот алг УЗОР нач нц 2 раз нц 4 раз закрасить; вниз вниз
Исполнитель Робот
Исполнитель Робот
использовать Робот алг нач нц пока снизу свободно нц пока справа
использовать Робот алг нач нц пока снизу свободно нц пока справа
использовать Робот алг нач нц пока снизу свободно вниз; закрасить;
использовать Робот алг нач нц пока снизу свободно вниз; закрасить;
Команды условных алгоритмов
Команды условных алгоритмов
Закрасить все клетки коридора, из которых есть выход вверх
Закрасить все клетки коридора, из которых есть выход вверх
Робот внутри коридора неизвестного направления
Робот внутри коридора неизвестного направления
Задачи
Задачи
Дано: На поле Робота горизонтальный коридор шириной в одну клетку
Дано: На поле Робота горизонтальный коридор шириной в одну клетку
Исполнитель Робот
Исполнитель Робот
Алг нач нц пока сверху свободно вверх кц нц пока сверху стена вправо
Алг нач нц пока сверху свободно вверх кц нц пока сверху стена вправо
Команды условных алгоритмов
Команды условных алгоритмов

Презентация: «Исполнитель Робот». Автор: Женька. Файл: «Исполнитель Робот.ppt». Размер zip-архива: 1961 КБ.

Исполнитель Робот

содержание презентации «Исполнитель Робот.ppt»
СлайдТекст
1 Исполнитель Робот

Исполнитель Робот

СКИ, обстановка

2 Обстановка Робота

Обстановка Робота

Исполнитель Робот существует в некоторой обстановке — прямоугольном поле, разбитом на клетки, между которыми могут стоять стены. Робот может передвигаться по полю, закрашивать клетки.

3 Робот-> Сменить стартовую обстановку

Робот-> Сменить стартовую обстановку

Файл со стандартной обстановкой входит в поставку Кумира (10x16.fil). Стандартной обстановкой является пустая обстановка максимально допустимого размера 10*16 с Роботом в левом верхнем углу.

4 Исполнитель Робот
5 Инструменты->Редактировать стартовую обстановку

Инструменты->Редактировать стартовую обстановку

Поставить/убрать стену — щелкнуть по границе между клетками. Закрасить/сделать чистой клетку — щелкнуть по клетке. Переместить Робота — тащить мышью. Изменить размеры обстановки — команда «Новая обстановка» меню «Обстановка»

6 Исполнитель Робот
7 Исполнитель Робот
8 Описание алгоритма

Описание алгоритма

Алгоритм на языке КуМир записывается так: алг тип_алгоритма имя_алгоритма (описание_параметров) · дано условие_применимости_алгоритма · надо цель_выполнения_алгоритма нач · последовательность команд кон Описание алгоритма состоит из: • заголовка (часть до служебного слова нач) • тела алгоритма (часть между словами нач и кон)

9 Система команд исполнителя «Робот» включает:

Система команд исполнителя «Робот» включает:

Кумир-программа, управляющая Роботом, должна начинаться со строки использовать Робот 5 команд, вызывающих действия Робота (влево, вправо, вверх, вниз, закрасить) • 10 команд проверки условий: – 8 команд вида [слева/справа/снизу/сверху] [стена/свободно] – 2 команды вида клетка [закрашена/чистая]

10 Пример:

Пример:

использовать Робот алг нач · вправо · вниз · влево · вверх · закрасить кон

11 Команды циклических алгоритмов

Команды циклических алгоритмов

Нц число повторений раз · тело цикла (последовательность команд) кц нц пока условие · тело цикла (последовательность команд) кц нц для i от i1 до i2 · тело цикла (последовательность команд) кц

12 Задача 1 На поле Робота нет стен и закрашенных клеток

Задача 1 На поле Робота нет стен и закрашенных клеток

Сколько клеток будет закрашено после выполнения следующих команд:

Закрасить вправо вверх закрасить вправо закрасить вверх закрасить закрасить вправо

Закрасить вправо закрасить закрасить вправо вправо закрасить закрасить закрасить вправо

13 Задача 4

Задача 4

Петя составил алгоритм, а Коля стер в нем одну команду: алг прогулка дано ?на поле Робота стен нет надо ? Робот погулял и вернулся в исходное положение нач | вверх | вправо | ??? | вниз | влево | влево кон Какую команду стер Коля?

14 Задача 5 - 6

Задача 5 - 6

Петя составил алгоритм, при выполнении которого Робот вернулся в исходное положение. Коля стер одну из команд. При выполнении Колиного алгоритма Робот также вернулся в исходное положение. Какую команду стер Коля? Петя составил алгоритм, переводящий Робота из клетки А в клетку Б с закрашиванием каких-то клеток. Что должен сделать Коля с этим алгоритмом, чтобы получить алгоритм, переводящий Робота из Б в А и закрашивающий те же клетки.

15 Цикл N раз

Цикл N раз

Используется, когда некоторую последовательность команд нужно выполнить несколько раз подряд нц число повторений раз ? тело цикла кц Число повторений – целое число

16 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

17 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

18 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

19 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

20 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

21 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

22 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

23 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

24 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

25 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

26 Пример использования цикла

Пример использования цикла

алг диагональ дано ?на поле Робота стен нет надо ? Робот закрасил 4 клетки по диагонали нач | нц 3 раз | | закрасить; вправо; вниз; | кц | закрасить кон

А

Б

27 Пример

Пример

алг лабиринт дано ?Робот в клетке А надо ?Робот в клетке Б нач | нц 5 раз | | вверх; вверх; вверх | | вправо | | вниз; вниз; вниз | | вправо | кц кон

А

Б

28 Нарисуем треугольник

Нарисуем треугольник

Алг треугольник нач | нц 4 раз | | вправо | кц | нц 4 раз | | закрасить; вправо; вниз | кц | нц 8 раз | | закрасить; влево | кц | нц 4 раз | | закрасить; вправо; вверх | кц кон

А

29 Еще один пример

Еще один пример

А

Б

Алг рисунок нач | нц 3 раз | | вправо; закрасить | | вниз; закрасить; | | вниз; закрасить | | влево; вверх; закрасить | | вправо; вправо; закрасить | | вправо; вправо; вверх | кц кон

Рисуем плюс

Переходим к следующему

30 Домашнее задание

Домашнее задание

Придумать 2 фигуры и запрограммировать их рисование Роботом с использованием цикла N раз (проверить в программе и перенести в тетрадь

31 Робот находится в левом верхнем углу поля

Робот находится в левом верхнем углу поля

Составить алгоритм, закрашивающий данные клетки.

32 Робот находится в левом верхнем углу поля

Робот находится в левом верхнем углу поля

Составить алгоритм, закрашивающий данные клетки.

33 Б

Б

А

Составить алгоритм перемещения робота по лабиринту из положения А в положение Б.

34 Цикл пока

Цикл пока

Нц пока условие · тело цикла (последовательность команд) кц

35 10 команд проверки условий

10 команд проверки условий

Сверху стена сверху свободно снизу стена снизу свободно справа стена справа свободно слева стена слева свободно клетка закрашена клетка чистая

36 Закрашивание ряда до стены

Закрашивание ряда до стены

Алг закрасить ряд вправо до стены и вернуться нач нц пока справа свободно закрасить; вправо кц закрасить нц пока клетка закрашена влево кц вправо кон

37 Закрашивание горизонтального коридора произвольной длины, робот где-то

Закрашивание горизонтального коридора произвольной длины, робот где-то

в коридоре

Алг закрасить коридор нач нц пока снизу стена влево кц вправо нц пока снизу стена закрасить; вправо кц кон

38 Задания

Задания

Закрасить клетки у стен прямоугольника, робот где-то внутри прямоугольника Левее робота есть закрашенная клетка, закрасить все клетки между роботом и этой клеткой и вернуться назад Закрасить вертикальный коридор неизвестной длины, робот где-то в коридоре Робот в клетке над горизонтальной стеной неизвестной длины, закрасить все клетки вокруг стены

39 Величины

Величины

Описание величин: указать тип, имя в теле алгоритма после слова нач Примеры имен: s, R, б, а1 Тип величины: вещ, цел Например: алг нач цел а,б

40 Величины

Величины

Ввод величин ввод s ввод s, а1 Вывод величин вывод s вывод s, а1 Присваивание величинам значений: s:=5; a1:=a1*2

41 Вывести два числа, вывести их сумму

Вывести два числа, вывести их сумму

Алг нач цел а, б ввод а, б вывод а+б кон

42 Цикл «для»

Цикл «для»

Нц для i от i1 до i2 шаг b · тело цикла кц где i, b, i1 и i2 величины целого типа i1<=i2 и b>0, i1>=i2 и b<0 например: нц для i от 1 до 5 · закрасить; вправо кц

43 Исполнитель Робот
44 Закрасить клетки по периметру прямоугольника размером X на Y

Закрасить клетки по периметру прямоугольника размером X на Y

Алг нач цел x,y,i ввод x,y нц для i от 1 до х-1 закрасить; вправо кц нц для i от 1 до y-1 закрасить; вниз кц нц для i от 1 до х-1 закрасить; влево кц нц для i от 1 до y-1 закрасить; вниз кц кон

45 Цикл n раз

Цикл n раз

Нц число повторений раз · тело цикла (последовательность команд) кц

46 использовать Робот алг нач нц 5 раз · закрасить;вправо;вверх кц нц 5

использовать Робот алг нач нц 5 раз · закрасить;вправо;вверх кц нц 5

раз · закрасить;вправо;вниз кц закрасить кон

47 Исполнитель Робот
48 Исполнитель Робот
49 Вложенные циклы

Вложенные циклы

Нц число повторений раз нц число повторений раз тело цикла· кц ·кц

50 использовать Робот алг УЗОР нач нц 2 раз нц 4 раз закрасить; вниз вниз

использовать Робот алг УЗОР нач нц 2 раз нц 4 раз закрасить; вниз вниз

закрасить; вправо вверх; закрасить; вверх; вправо вправо кц· закрасить; вниз вниз; закрасить; вправо вверх; закрасить; вниз; вниз; нц 13 раз влево кц кц нц 4 раз закрасить; вниз вниз; закрасить; вправо вверх; закрасить; вверх; вправо; вправо кц· закрасить; вниз вниз; закрасить; вправо вверх; закрасить; кон

51 Исполнитель Робот
52 использовать Робот алг нач нц пока снизу свободно нц пока справа

использовать Робот алг нач нц пока снизу свободно нц пока справа

свободно вниз; закрасить; вправо; закрасить; вверх; закрасить; вправо; закрасить; вправо кц вниз; вниз; вниз нц пока слева свободно влево кц кц кон

53 использовать Робот алг нач нц пока снизу свободно вниз; закрасить;

использовать Робот алг нач нц пока снизу свободно вниз; закрасить;

вниз вправо; закрасить; вправо вверх; закрасить; вверх; влево; закрасить; вправо вправо; нц пока справа свободно вправо; вниз; закрасить; вниз; вправо; закрасить; вправо вверх; закрасить; вверх; влево; закрасить; вправо вправо; кц вниз; вниз; вниз; нц пока слева свободно влево кц кц кон

54 Команды условных алгоритмов

Команды условных алгоритмов

Если условие · то серия 1 · иначе серия 2 все если условие · то серия 1 все

55 Закрасить все клетки коридора, из которых есть выход вверх

Закрасить все клетки коридора, из которых есть выход вверх

Нц пока снизу стена если сверху свободно то закрасить; вправо иначе вправо все кц

56 Робот внутри коридора неизвестного направления

Робот внутри коридора неизвестного направления

Вывести робот из коридора

Если справа свободно то нц пока снизу стена вправо кц иначе нц пока справа стена вверх кц все

57 Задачи

Задачи

В горизонтальном коридоре есть тупики снизу размером в 1 клетку, робот в левой клетке коридора. Вывести робот из коридора вправо и закрасить тупики. На поле нет стен. В ряду из 10 клеток правее робота некоторые клетки закрашены. Закрасить клетки ниже каждой закрашенной. Робот находится внутри прямоугольника. Некоторые клетки в левой вертикали прямоугольника закрашены. Закрасить соответствующие им клетки в правой вертикали.

58 Дано: На поле Робота горизонтальный коридор шириной в одну клетку

Дано: На поле Робота горизонтальный коридор шириной в одну клетку

Коридор имеет выступы-ответвления вниз произвольной длины, ширины — в одну клетку. Ответвления заканчиваются тупиком. Робот находится в одном из ответвлений. Надо: Робот закрасил коридор и все ответвления и вышел из коридора влево.

59 Исполнитель Робот
60 Алг нач нц пока сверху свободно вверх кц нц пока сверху стена вправо

Алг нач нц пока сверху свободно вверх кц нц пока сверху стена вправо

кц влево нц пока сверху стена если снизу свободно то нц пока снизу свободно вниз кц нц пока сверху свободно закрасить; вверх кц все закрасить;влево кц кон

61 Команды условных алгоритмов

Команды условных алгоритмов

Выбор условие · при условие 1: серия 1 · при условие 2: серия 2 · . . . · при условие n: серия n · иначе серия n+1 все

«Исполнитель Робот»
http://900igr.net/prezentacija/informatika/ispolnitel-robot-131166.html
cсылка на страницу
Урок

Информатика

130 тем
Слайды